"Printer not connected; will retry in 30 seconds..."

Otto Paulsen otto.paulsen at itema.no
Tue Oct 23 13:18:28 PDT 2007

I have had this problem for a very long time and tried a lot with no success. Please help me.

I have installed CUPS on a Linksys NSLU2 running Unslung (V2.3R29-uNSLUng-5.5-beta).
One of the main functions I use it for is as print server.
I have connected a Canon PIXMA iP5000 via USB.

It worked well for some time, but a while ago it suddenly stopped working. It was after I ran an ipkg -upgrade and got a new version of cups. It is actually long time ago. Maybe a year or more.

The message I get in the admin console is "Printer not connected; will retry in 30 seconds..." .
I have tried to print a file directly to the printer using  "cat t.prn > /dev/usb/lp0" and it works fine, so I guess the problem is in cups.

The printer is installed like this:
Printer Driver: Local Raw Printer
Printer State: processing, accepting jobs, published.
Device URI: usb:/dev/lp0

CUPS is version 1.3.3.

What can I try to get this fixed?

More information about the cups-devel mailing list