[cups.bugs] cups crash

Stefano Sabatini stefano.sabatini-lala at poste.it
Wed Sep 3 14:56:09 PDT 2008

Hi all, this is my first post here so I want to thank you for the nice

I'll start with quite a long story, please skip to the last paragraphs
if you don't feel like to read it.

Today I decided that I wanted to print an emacs buffer showing some
code which I wanted to study not in front of my computer.

So I read the emacs manual, run the (print-buffer) command and nothing
happened. So I decided that it was the time to learn the command line
tools privided by the spool system (I learn this term later).

I started to read around in the web starting from linuxprinting.org,
and so I started to familiarize with all the exoterica of the printing
technology, PPD, LPC, RIP. While I still didn't manage to exactly
understand the exact distinction between what provides gutenprint (ex
gimp-print) and foomatic (but I love this name so much...), I realized
that I need to choose amongst the various solutions.

So I decided to stick with cups+foomatic+gutenprint (still cannot
exactly understand their exact difference as most users) so I manage
to install all the last versions of these packages provided in my

So they are:
cups-common + cups-utils
foomatic-db-engine 3.0.2
foomatic-db-gutenprint 5.0.2-4
cups-driver-gutenprint 5.0.2-4
gimp-gutenprint 5.0.2-4

Next just for fun I tried to check the Gnome interface:
System -> Administration -> Printing

Here I could see the list of all the installed printers. I wanted to
change the default one, so I right-clicked on the printer icon I want
to set and clicked on the "Make default" option in the contextual
menu. It hanged for some seconds them all the icons disappeared. The
cups server was gone.

Then I tried to reproduce the experience via commandline.
Started to read man lpstat, and started to experiment.

Here it is what happened:
stefano at geppetto ~> sudo /etc/init.d/cups start
Starting Common Unix Printing System: cupsd.
stefano at geppetto ~> lpstat -r
scheduler is running
stefano at geppetto ~> lpstat -t
scheduler is running
system default destination: LaserJet-3050
lpstat: Unknown
lpstat: Unknown
lpstat: Unknown
lpstat: Unknown
lpstat: Unknown
stefano at geppetto ~> lpstat -r
lpstat: Unable to connect to server

lpstat -t is crashing the server. So now I wonder, there is some way
to debug this? Is it a known problem?

BTW, where should I ask general usage question, even if not related to
some bugs?

Sorry for the long post and thanks for your attention so far.

Best regards.

More information about the cups-devel mailing list