New CUPS 1.2.X unable to install printer as root

Nathan S. candid at
Mon Jul 5 14:23:33 PDT 2004

I have come to the conclusion that CUPS is not ready for anything but headaches.  I've had nothing but problems for six months of tweaking, reinstalling, upgrading, asking questions that remain unanswered, etc.  Thank god it is free.

If anyone can give me a hint of any other printing system that works well with a Samsung ML1650, please let me know...Not that this is the only printer that I've had problems with concerning CUPS. I have problems with any printer using CUPS and Slackware 9.1, as my earlier unanswered posts would show.  I recieved one response with the idea of using lprng, but I was attempting to work with CUPS in the mistaken belief that it worked.

Originally, my printer would work great...if I didn't reboot or restart the cups daemon.  If I happened to do either of those forbidden tasks, the daemon would die and the only way to get it to work again would be to delete /etc/cups and reinstall the software and printer.

I scoured through the logs and the internet for months, attempted posting requests, and receive nothing but the single response...2 months later from a person that had a similar situation, also receiving no response and having no solution.

Now I've installed the latest version of 1.2.x thinging that it would fix the problem.  But, like a Microsoft(TM) product, the new "features" have made it impossible to install a printer.  As root, if I attempt to add a printer through the web interface, it plops me back to the main screen.  Also as root, if I try to add using KDE's interface, it states:

"Unable to create printer. Error message received from manager:
You are not authorized to access the requested resource."

I've changed nothing, and the printer is located on the standard /dev/lp0.  All I've done us upgrade to the new 1.2.x version via CVS.  I've tried to revert to a 1.1.x version, but it fails to install.  1.2.x installs, but will not allow any printers to be added.  And, I'm sure if it did then my cupsd would fail if I rebooted my machine.

I only hope there are those that have better luck than I.  Right now all I've got is a 50 lbs. paperweight and a headache, with no time to deal with this.  I won't hold my breath for any responses.


Nathan S.

More information about the cups mailing list