[cups.general] The Famous "Media tray empty!" error - revisited

Vincenzo Romano RomanoVincenzo at Yahoo.COM
Sun Jul 4 14:25:30 PDT 2004

Hi there all.

I've just hit my head on this problem. It seems to me it's due to
a problem with the backend. As far as I've seens on the web, only
*USB* printers run in the problem.
Now, I've been using my Samsung ML1710P (USB+Parallel) for a while with
no  problem at all. And suddenly it stopped working.
What has appened in my system is that I've done an upgrade of the compiler *and* an upgrade of the kernel.
I'm running:
- Gentoo 2004.1
- CUPS 1.1.20
- gcc 3.3.3 (Gentoo Hardened Linux 3.3.3-r6, ssp-3.3.2-2, pie-8.7.6)
- Kernel 2.6.6 or 2.6.6-mm5

I've seens somewhere a posting from a guy switching from USB to Parallel and solving the problem so, what I can argue is that:
1. either the USB backend gor hurted by the compiler
2. or the Linux USB-Printer support got hurted by some "code fix" or by the new gcc
3. or a mix of these two.

At the moment I have no parallel cable to test, but am pretty sure that this is the way to solve the problem. Maybe.


"Steven P. Ulrick" wrote:
> Hello, Everyone :)
> I hope I am not starting off my involvement with this list on a bad
> foot, but my question has appeared many times on the CUPS news
> groups/mailing lists, but I found no real solution in everything that I
> read.
> I am attempting to set up our printer, a Samsung ML1250 Laser Printer.
> It is connected to the USB port.  The queue type is locally-connected,
> and the device is /dev/usb/lp0  Everything seems ok, until I try to
> print anything, and I get the legendary "Media tray empty!" error.  Of
> course, like I'm sure you are used to hearing, the media tray is not
> empty.
> Here is the log message from an attempt to print something:
> I [01/Jul/2004:02:50:53 -0500] Started "/usr/lib/cups/cgi-bin/admin.cgi" (pid=29845)
> I [01/Jul/2004:03:11:48 -0500] Started "/usr/lib/cups/cgi-bin/admin.cgi" (pid=11344)
> I [01/Jul/2004:03:36:09 -0500] Adding start banner page "none" to job 18.
> I [01/Jul/2004:03:36:09 -0500] Adding end banner page "none" to job 18.
> I [01/Jul/2004:03:36:09 -0500] Job 18 queued on 'SamsungML1250LaserPrinter' by 'steve'.
> I [01/Jul/2004:03:36:09 -0500] Started filter /usr/lib/cups/filter/pstops (PID 5130) for job 18.
> I [01/Jul/2004:03:36:09 -0500] Started filter /usr/lib/cups/filter/foomatic-rip (PID 5131) for job 18.
> I [01/Jul/2004:03:36:09 -0500] Started backend /usr/lib/cups/backend/usb (PID 5132) for job 18.
> W [01/Jul/2004:03:36:10 -0500] [Job 18] Media tray empty!
> I [01/Jul/2004:03:38:09 -0500] Scheduler shutting down normally.
> I need to make very clear that up until a week or so ago, this printer
> Just Worked everytime I would have to reconfigure it.  This is the first
> time I've ever had an issue with this printer, or CUPS, so this is a
> complete mystery to me.
> When I ran "system-config-printer", when it got to the part where it
> asked me to pick a manufacturer, I picked "Samsung"  When asked for the
> model of my printer, I found the exact model "ML1250"  I chose, as
> always, the driver that was reccomended.  This has always worked before.
> A little system information:
> Operating System: Fedora Core 2
> Installation type: Full Installation (not an upgrade)
> Update status: all official updates applied
> KDE: from CVS HEAD
> QT: from TrollTech source
> (QT and KDE are both in non-default locations.  I did not overwrite my
> default KDE.)
> CUPS is the current Fedora Core 2 version, from the Updates-Released server.
> Again, this is a new issue for me, so please let me know what I need to
> tell you to clarify this :)
> Steven P. Ulrick

More information about the cups mailing list