[cups.general] Access forbidden

Doctorcam cam at ellisonet.ca
Thu Jul 15 14:23:54 PDT 2004

This is a follow-up to an earlier posting (from yesterday):

I am running 1.1.20 (Debian testing version) and cannot get past the
point of installing a printer.  Every attempt to modify or print gets
a 403 response.

Here's cupsd.conf:

ServerName treehouse.ellisonet.ca
DefaultCharset notused
LogLevel debug2
Printcap /var/run/cups/printcap
BrowseAllow 192.168.1.*
BrowseOrder allow,deny
SystemGroup lpadmin
<Location />
Order Deny,Allow
Deny From All
Allow From
<Location /printers/name>
Order Deny,Allow
Deny From All
Allow From .ellisonet.ca
<Location /admin>
AuthType Basic
AuthClass SystemGroup
Order Deny,Allow
Deny From All
Allow From

Here is a relevant chunk of /var/log/cups/error_log:

d [15/Jul/2004:12:17:32 -0700] AcceptClient(lis=0x808c758) 0 NumClients = 1
D [15/Jul/2004:12:17:32 -0700] AcceptClient: 7 from treehouse.ellisonet.ca:631.
d [15/Jul/2004:12:17:32 -0700] AcceptClient: Adding fd 7 to InputSet...
d [15/Jul/2004:12:17:32 -0700] ReadClient: 7, used=0, file=-1
D [15/Jul/2004:12:17:32 -0700] ReadClient: 7 GET /admin/?op=modify-printer&printer_name=HP1300 HTTP/1.1
d [15/Jul/2004:12:17:32 -0700] decode_auth(0x40423c3c): Authorization string = ""
d [15/Jul/2004:12:17:32 -0700] decode_auth: 7 username=""
d [15/Jul/2004:12:17:32 -0700] IsAuthorized: con->uri = "/admin/?op=modify-printer&printer_name=HP1300"
d [15/Jul/2004:12:17:32 -0700] FindBest: uri = "/admin/?op=modify-printer&printer_name=HP1300"...
d [15/Jul/2004:12:17:32 -0700] FindBest: Location CUPS_INTERNAL_BROWSE_ACL Limit 0
d [15/Jul/2004:12:17:32 -0700] FindBest: Location / Limit 7f
d [15/Jul/2004:12:17:32 -0700] FindBest: Location /printers/name Limit 7f
d [15/Jul/2004:12:17:32 -0700] FindBest: Location /admin Limit 7f
d [15/Jul/2004:12:17:32 -0700] FindBest: best = "/admin"
d [15/Jul/2004:12:17:32 -0700] IsAuthorized: auth = 1, satisfy=0...
d [15/Jul/2004:12:17:32 -0700] ReadClient: Unauthorized request for /admin/?op=modify-printer&printer_name=HP1300...
D [15/Jul/2004:12:17:32 -0700] SendError: 7 code=403 (Forbidden)
D [15/Jul/2004:12:17:32 -0700] CloseClient: 7
d [15/Jul/2004:12:17:32 -0700] CloseClient: Removing fd 7 from InputSet and OutputSet...

I have tried setting AuthType to None, with the same result.

I assume that I have something wrong in cupsd.conf, though until
sometime yesterday, everything was working fine.

When I access localhost:631/admin, I now get no request to log in,
though I did earlier.  I have since purged cups from the system, and
am prepared to try again to re-install.


Cam Ellison  Ph.D.  R.Psych. #01417

Cam Ellison & Associates Ltd.
Management Psychology

RR 22    3446 Beach Avenue
Roberts Creek  BC  V0N 2W2

Phone: 604-885-4806
Fax:   604-885-4809

More information about the cups mailing list