[cups.general] Problem printing with cups 1.1.20/1.1.19

Rob Keeling rob at rjkeeling.freeserve.co.uk
Sat Jul 3 10:48:47 PDT 2004

I have hit a bit of a problem with printing from a Suse 9.1 box running cups
1.1.20 to a Suse 8.2 print server
running Cups 1.1.19.

I can configure /etc/cups/client.conf to point to the 8.2 print server, and
everything works, however the workstation
sees all the 30 odd print queues on the printer server. I only want the
workstaion to see 3 of the printers.

I have tried running cups on the workstation, adding the three printers
using lpadmin -p <printername> ipp://qegs-printers/printers/<printername>
Which worked, but mozilla Firefox would not print! In fact it stops the
print queue with the error "EMPTY PRINT FILE!" once you attempt
to print from Firefox.

Is there either a way of restricting which printers are used by the clients,
or making firefox print?


Rob Keeling


I love deadlines.   I love the whooshing noise they make as they go by.
- Douglas Adams

More information about the cups mailing list