[cups.general] CUPS can't find printer (sort of)

Steven P. Ulrick ulrick2 at faith4miracle.org
Tue Jul 20 13:05:20 PDT 2004

On Tue, 20 Jul 2004 10:40:53 -0700
Doctorcam <cam at ellisonet.ca> wrote:

> This is an odd one, and has led me to completely purging CUPS from
> three systems and re-installing, with no change.
> There are 2 printers served by one box, which is the gateway for the
> LAN.  When CUPS is installed, test pages run fine, and access is
> straightforward. 
> The next day, nothing prints even though the item is spooled OK,
> localhost:/631/printers has an error message to the effect that it
> can't find the printer (usb), and any attempt to modify, configure,
> etc. the printer (as root) gets a 403 response.
> When this happens, I Add a Printer, using exactly the same
> information, and the relevant printer resets itself.  Then it prints
> just fine, and the error message (after closing the web page and
> re-opening it) goes away.
> Has anyone encountered this, and if so, what did you do about it?
> Cam

Hello :)
Take courage, my friend :)  You are not alone :)  I don't know what
caused it, and I don't know what ended up permanently fixing it, but I
did discover a workaround that worked every time.  In my case, when I
switched runlevels (I Suppose that rebooting would have done it, I never
tried it :)) when I came back to runlevel 5, our printer was "gone"  My
workaround, even though the startup messages said that CUPS had started
ok, was to run:
/etc/init.d/cups restart
After doing this, in KControl, a few times I just sat there and watched
our printer magically reappear :)  Then all was well.
(I use Fedora Core 2.  If you don't, the command I gave might need to be
slightly altered for your system.)

If this helped you, I will take great pleasure in that :)

Steven P. Ulrick

More information about the cups mailing list