[cups.general] CUPS and Asante cable router LPD printer Port

Nathan Viswanathan nathanv at rogers.com
Tue Jul 20 10:31:10 PDT 2004

I am running suse9.1 pro. Usinf hp lj 6p attached to the above asante 
cable router built in parallel port providing LPD service.
I am new to Linux. First tried RH8 and the printer worked defining as 
lpr and queue as lp.  I  switched over to suse 9.1  as I found that rh8 
support is not availabe. I am having tough time with cups to make my 
printer work. Defined as network printer

RH8 Printcap: Worked

# /etc/printcap


Q1: I read many documents in various places to fix the cups  problem. 
Learned quite a bit but not to the level to fix  the printing. Michael 
got me out of the mud when cupsd.conf  problem (cups abend 98) due to 
yast (suse configurator)  bogged me down for 5 days.  Where can I learn 
about CUPS setup for above lp configuration  step by step?

Q2: How cups supports this  lpd server?   Does cups server  on pc talk 
to lpd/ Where cups client comes to play?

Q3: What is foomatic and PPD? Which one to use? How they are used?
I see laserjet.ppd and hpijs.ppd in the model file.

Q4. With the following confign, printing light comes on and nothing prints!

Suse printers.conf:
# Printer configuration file for CUPS v1.1.20
# Written by cupsd on Tue 29 Jun 2004 09:01:12 PM EDT
<DefaultPrinter lp>
Info hp1
Location b1
DeviceURI lpd://
State Idle
Accepting Yes
JobSheets none none
QuotaPeriod 0
PageLimit 0



Q5: Is ther any free 3rd party cups like package available?

Thanks for the help.


More information about the cups mailing list