cups not working after lightning strike

Kevin H. Phillips kh-phillips at
Sat Jul 10 14:50:02 PDT 2004

Paulo R. Dallan wrote:

> Kevin, ok, so:
> Did you restart cups?
> What are the errors being described *in* the error log (the error log in set
> up mode is quite detailed...)
> Is there a firewall active?
> What are the commands you are issuing when trying to print? (lp & lpr won't
> probably work, try lp-cups or lpr-cups).
> Regards!
> Paulo
Sorry to be so long replying again.  My Internet connection was down for 
a few more days and I've been busy.

1.  Yes, I restarted cups
2.  I'm not seeing any errors described in the error log.  It always 
shows the jobs as "completed".
3.  Yes, there is a firewall active (Firestarter)
4.  I did have the "location" set to /dev/lp0.  I've tried changing that 
to lp-cups or lpr-cups and it still is not printing.

I guess I'm not sure what settings I'm supposed to put where; I've 
always just used /dev/lp0 before and it worked.    Also, I've been 
plugging in different drivers to see if I could get anything to work 
(e.g. CUPS+GIMP-PRINT and also ESP PrintPro)


More information about the cups mailing list