[cups.general] The Famous "Media tray empty!" error - revisited

Steven P. Ulrick ulrick2 at faith4miracle.org
Tue Jul 6 08:35:21 PDT 2004


On Tue, 6 Jul 2004 16:04:01 +0100
Tim Waugh <twaugh at redhat.com> wrote:

> On Tue, Jul 06, 2004 at 09:54:44AM -0500, Steven P. Ulrick wrote:
> 
> > I just compiled and installed CUPS from CVS (the development
> > version) It APPEARED to compile and install fine (with the correct
> > version of usb.c in place)
> > The only problem is, I've had multiple hard lockups while attempting
> > to print test pages (our computer almost never locks up.  This is
> > very unusual.)
> 
> If you're just trying to avoid the "media tray empty" error then
> you're better off downgrading to whatever you had before.  The error
> message is entirely harmless.
> 
> Tim.

Hello, Tim :)
I have some good news, and some bad news: the good news is the printer
now works perfectly.  The bad news is that I have no idea what I did to
fix it :(  What I do know is that I force-installed cups and cups-libs,
and then everything Just Worked again :)  I then installed the latest
Fedora Core 2 updates for CUPS, and everything STILL works.  I'm glad
that it works now, but I'd still like to know two things (none of which
you can probably answer :)):
1. What caused my inability to print to begin with?
2. And why couldn't I get it to work before?  The incident that lead to
my Linux-Guru brother calling me a genius involved CUPS, and doing what
preceeded this fix: force reinstalling the CUPS RPM's.

Anyway, thank you for your patience :)

Steven P. Ulrick





More information about the cups mailing list