New CUPS 1.2.X unable to install printer as root

Nathan S. candid at
Tue Jul 6 15:19:42 PDT 2004

Helge Blischke wrote:

> Michael Sweet wrote:
> > AFAIK, the ML1650 is not well supported under Linux, and I don't  have
> > any suggestions for you or your problems.
> >

> According to, this printer is marked as "works
> perfectly"
> at that site, and the recommended driver is based on Ghostscript's
> pxlmono (using
> the foomatic approach).
> Nathan, perhaps you try to follow the hints given there.

I have.  Thanks for the response!  I'm sorry I was so short, but I've become a little frustrated over the last 6 months.  Let me summarize:

The exact problem, error logs, and configuration are located at the prior posts by myself on March 12, 2004:

1. CUPS 1.2.x is available for download and I've been using it for months.  There is no notification on the download page ( ) that 1.2.x is unusable.  Also, when I tried to install CUPS 1.1.x it failed, as admitted here:

2. I use Slackware 9.1.  Slackware 10.0 was released 1 week ago and I have not yet upgraded.  That may be my next step.

3. I have NO PROBLEMS WHATSOEVER with my printer and CUPS *when CUPS works*.  However, as stated before, if I REBOOT the computer or RESTART CUPS the cupsd will start, but if I attempt to print or connect to the printer in any way (web interface or via KDE Print Manager) cupsd fails.  If I check the processes, cupsd is no longer listed and I get an error that I cannot connect to the host (because cupsd has crashed).

4. Why would I pay for something that doesn't work?  If I wanted to do that I'd buy Microsoft(TM).  My goal is to get the system working at home (testing grounds) and bring it into production at the office.  If I can't get it working at home, I'm not going to pay for it at the office.

I appreciate any help possible.  I'm not a computer engineer, but I know enough to know when I'm in over my head.  I've tried everything I can possibly think of, and I love CUPS when it works.  But, it gets to be annoying when you have to delete /etc/cups and reinstall CUPS and the printer every time I reboot, the power goes out, or I restart the daemon.  I could even deal with that (and have been for months) until now that CUPS won't let me install any printer, even as root.  These are obviously problems with CUPS, and may be problems with its interaction with Slackware, but I don't know enough of either to know what would cause the daemon to crash or to deny even root the ability to install a printer.

Thanks for the suggestions!  I'm just frustrated right now and don't have the time to really deal with it (I'm studying for a big test).

Take care!


More information about the cups mailing list