[cups.general] CUPS can't find printer (sort of)

Doctorcam cam at ellisonet.ca
Wed Jul 21 11:50:51 PDT 2004

* Steven P. Ulrick (ulrick2 at faith4miracle.org) wrote:
> Hello :)
> Take courage, my friend :)  You are not alone :)  I don't know what
> caused it, and I don't know what ended up permanently fixing it, but I
> did discover a workaround that worked every time.  In my case, when I
> switched runlevels (I Suppose that rebooting would have done it, I never
> tried it :)) when I came back to runlevel 5, our printer was "gone"  My
> workaround, even though the startup messages said that CUPS had started
> ok, was to run:
> /etc/init.d/cups restart
> After doing this, in KControl, a few times I just sat there and watched
> our printer magically reappear :)  Then all was well.
> (I use Fedora Core 2.  If you don't, the command I gave might need to be
> slightly altered for your system.)

Restarting cupsd does not have any impact on this.  Re-installing the
printer does, without exception.  The printer will go off-line at
times (and needs to be power-cycled), which triggers the lock-up.  My
guess is that it is not actually the printer that is at fault, but
something in the USB software.  What is bizzare is that cups will not
allow access to anyone, including root. Running at debug level
provides no clues that I can see. 



Cam Ellison  Ph.D.  R.Psych. #01417

Cam Ellison & Associates Ltd.
Management Psychology

RR 22    3446 Beach Avenue
Roberts Creek  BC  V0N 2W2

Phone: 604-885-4806
Fax:   604-885-4809

More information about the cups mailing list