[cups.general] The Famous "Media tray empty!" error - revisited

Steven P. Ulrick ulrick2 at faith4miracle.org
Thu Jul 1 02:24:37 PDT 2004

Hello, Everyone :)
I hope I am not starting off my involvement with this list on a bad
foot, but my question has appeared many times on the CUPS news
groups/mailing lists, but I found no real solution in everything that I
I am attempting to set up our printer, a Samsung ML1250 Laser Printer. 
It is connected to the USB port.  The queue type is locally-connected,
and the device is /dev/usb/lp0  Everything seems ok, until I try to
print anything, and I get the legendary "Media tray empty!" error.  Of
course, like I'm sure you are used to hearing, the media tray is not

Here is the log message from an attempt to print something:
I [01/Jul/2004:02:50:53 -0500] Started "/usr/lib/cups/cgi-bin/admin.cgi" (pid=29845)
I [01/Jul/2004:03:11:48 -0500] Started "/usr/lib/cups/cgi-bin/admin.cgi" (pid=11344)
I [01/Jul/2004:03:36:09 -0500] Adding start banner page "none" to job 18.
I [01/Jul/2004:03:36:09 -0500] Adding end banner page "none" to job 18.
I [01/Jul/2004:03:36:09 -0500] Job 18 queued on 'SamsungML1250LaserPrinter' by 'steve'.
I [01/Jul/2004:03:36:09 -0500] Started filter /usr/lib/cups/filter/pstops (PID 5130) for job 18.
I [01/Jul/2004:03:36:09 -0500] Started filter /usr/lib/cups/filter/foomatic-rip (PID 5131) for job 18.
I [01/Jul/2004:03:36:09 -0500] Started backend /usr/lib/cups/backend/usb (PID 5132) for job 18.
W [01/Jul/2004:03:36:10 -0500] [Job 18] Media tray empty!
I [01/Jul/2004:03:38:09 -0500] Scheduler shutting down normally.

I need to make very clear that up until a week or so ago, this printer
Just Worked everytime I would have to reconfigure it.  This is the first
time I've ever had an issue with this printer, or CUPS, so this is a
complete mystery to me.
When I ran "system-config-printer", when it got to the part where it
asked me to pick a manufacturer, I picked "Samsung"  When asked for the
model of my printer, I found the exact model "ML1250"  I chose, as
always, the driver that was reccomended.  This has always worked before.

A little system information:
Operating System: Fedora Core 2
Installation type: Full Installation (not an upgrade)
Update status: all official updates applied
QT: from TrollTech source
(QT and KDE are both in non-default locations.  I did not overwrite my
default KDE.)
CUPS is the current Fedora Core 2 version, from the Updates-Released server.

Again, this is a new issue for me, so please let me know what I need to
tell you to clarify this :)

Steven P. Ulrick

More information about the cups mailing list