[cups.general] Re: New CUPS 1.2.X unable to install printer as root

Steven P. Ulrick ulrick2 at faith4miracle.org
Thu Jul 15 11:22:47 PDT 2004

On Thu, 15 Jul 2004 12:33:39 -0500
"Nathan S." <candid at NOSPAMhotmail.com> wrote:

> On Tue, 06 Jul 2004 22:19:42 +0000, Nathan S. wrote:
> > Helge Blischke wrote:
> > 
> >> Michael Sweet wrote:
> >> > AFAIK, the ML1650 is not well supported under Linux, and I don't 
> >have> > any suggestions for you or your problems.
> >> >
> > 
> >> According to www.linuxprinting.org, this printer is marked as
> >"works> perfectly"
> >> at that site, and the recommended driver is based on Ghostscript's
> >> pxlmono (using
> >> the foomatic approach).
> the ML1650 is a great printer and i've had no problems with it.  i
> have finally found what i believe to be a workaround for my problem. 
> i've reverted to 1.1.20 that i download complete, not through cvs.  i
> saved it in a fresh directory, compiled, installed, and everything
> worked fine.
> my other problem that i've continually had is the reboot/restart
> problem(the cupsd would crash on reboot/restart).  my workaround that
> seems to be working for the time being is something so simple that it
> is stupid.  when i reboot and the cupsd crashes, all i need to do is:
> /etc/rc.d/init.d/cups reload
> it works fine after that.  no more deleting /etc/cups, reinstalling
> cups, and reinstalling the printer.  why "restart" doesn't work, i
> don't know. all i can say is that it is working now and i'm very
> happy!
> thanks for your help!
> nathan s.

Hello, Nathan :)
I read the above message with interest.  I have had what I believe to be
the same problem with our Samsung ML1250.  For a LONG time, it just
worked.  Never any problems configuring or using it.  But what I
discovered was, it would just "dissappear" when I changed runlevels
(say, runlevel 5 to runlevel 1.  When I went back to runlevel 5, our
printer was gone :()  But in my case, CUPS APPEARED to have started just
fine when I returned to runlevel 5, but the printer was gone!  Also in
my case, the command that you tried that DIDN'T work, is the one that
works for me: "/etc/rc.d/init.d/cups restart"  I will try the latest
stable version of CUPS (I am not running the CVS version.  I am running
the current updated version from Fedora Core 2) to see what happens :) 
But at least now, if I lose our printer, I can get it back Every time,
by running "/etc/rc.d/init.d/cups restart"

Have a Great Day :)
Steven P. Ulrick

More information about the cups mailing list