cupsd crashes on reboot/restart

Nathan S. candid at
Thu Jul 15 09:56:07 PDT 2004

Chris wrote:

> NS wrote:
> >
> > Problem:  If I reboot my machine or restart the cupsd daemon my printing fails.
> >
> > Observations:  cupsd is running when I ps -A until I try to access the printer, then cupsd fails.  I can restart it again, and it will be visible when I ps -A, yet it will fail again.

> I too share your pain.  I found I could kill the cupsd as much as i like and restart it but when I changed cupsd.conf and started it I get the same problem as you!  If you get a solution for this then please post here or mail me (remove the nospam).

ok, i may have found a workaround for our problem ( original post here: ).  maybe this was a solution that was too simple?  i'm still a linux novice, and i've been working on this problem since about december 2003, and i have found what appears to be a workaround for me.

for me, it boils down to one line:

/etc/rc.d/init.d/cups reload

i had been using /etc/rc.d/init.d/cups start (or restart), which would start cupsd but it would just crash again.  for whatever reason, i didn't think of using reload, maybe 'cause i didn't know what it would do or because i'd forgotten the command, 'cause i'm an idiot.  but, anyway, i was looking through the script and saw the command and decided to try it, and, low and behold, it seems to be working!

now, cupsd still crashes on reboot/restart, but now i know how to get it working again without deleting /etc/cups, reinstalling cups, and reinstalling my printer.  i can use this and be happy, if it keeps working.

thanks for the help!

Nathan S.

summary of how i came to workaround:

first of all, i tried all the versions of CUPS starting with the 1.2.x version, which failed for me.  this can be seen in the articles "New CUPS 1.2.X unable to install printer as root" at and subsequently at .

next, i tried the version that came with my linux distribution, v1.1.19, which never worked for me.  i then moved down the line and tried 1.1.21, but it failed to install because of a bug ( ).

i could finally get a version to install by downloading the cvs version of 1.1.x, but i could not install the printer as root as before.

i next created a new directory and downloaded a clean version of 1.1.20 from the web.  this installed without a hitch.  the cupsd crash was still around, though, so i started digging through the startup script.  i finally saw the "reload" option and decided to try it...and it worked.  why?  i have no idea.

i hope this helps someone!

More information about the cups mailing list