cupsd dies on lpadmin -x printername

bernd at bernd at
Sun Apr 10 11:49:08 PDT 2005

> Hello,
> On Apr 7 18:26 bernd at wrote (shortened):
> > Hi, on SuSE 9.2 with cups 1.21 when we remove a printer by using
> > the SysV command lpadmin -x printername cupsd aborts without any
> > message.
> Inspect the CUPS error_log for details.
> Regarding how to get detailed log messages see for example
> Kind Regards
> Johannes Meixner

Johannes, thanks for your reply.

I check that all you mentioned but had no success. Then, a bit frustated, I made a new installation from CD on a separat box, made a loop adding 20 printers and after that removed them in a second loop. In media every 10-th run of the loops cupsd dies. Last entry in the log is:
d [10/Apr/2005:20:04:07 +0200] FindBest: Location / Limit 7f
d [10/Apr/2005:20:04:07 +0200] FindBest: Location /admin Limit 7f
d [10/Apr/2005:20:04:07 +0200] FindBest: best = "/"
d [10/Apr/2005:20:04:07 +0200] IsAuthorized: auth = 0, satisfy=0...
d [10/Apr/2005:20:04:07 +0200] POST /
d [10/Apr/2005:20:04:07 +0200] CONTENT_TYPE = application/ipp
d [10/Apr/2005:20:04:07 +0200] ReadClient: 5 con->data_encoding = length, con->ddata_remaining = 292, con->file = -1

There is something wrong with the cups system in general. We have ca. 1000 printers spread over 10 customer systems, different printer models from different vendors, backend is socket and lpd. Per day there are ca. 50000 printjobs of any kind, plain ascii to big PS-Files.

The systems worked stable and fine until 9.0 prof. No problems, nothing! Starting with 9.2 (we skipped 9.1) the behavior changed.
Disabled printers without any reason to see. And very often per day the message: "CUPS: lpstat: get-printers failed: client-error-bad-request". When cupsd dies and we have to restart it all pending jobs for any printer are lost, I think it's not ok, too.

Different from other users of cups may be the usage of only system V printing style. We have our own filters (like the one found on HPUX before, modified for cups). We don't use the graphic tools for administration, only command lines. All this worked fine and stable as I mentioned above until 9.2.

I think we should wait for SuSE 9.3 and then see what it will bring. If the problems will still exist I'm afraid we have to debug the cupsd to see what goes wrong...

I hope not but may be I'll be back here in some weeks from now :-)

Thanks again (sorry for this long thread)
Bernd Rieke

More information about the cups mailing list