[cups.general] CUPS issue on my G-5

Hawker, Daniel Daniel.Hawker at animal.co.uk
Tue Apr 12 02:57:52 PDT 2005

> I am not sure if this is the right forum to ask this 
> question, but here goes...
> I run OS 10.3.8 on a G-5. I am trying to use the internal 
> modem for sending and receiving faxes.
> Apple did not create a way to see if your faxes were properly 
> sent. Someone at Apple had me use my browser... set it to 
> http://localhost:631/printers
> This gives me a screen that shows the printers I  have hooked 
> up including my internal modem. By viewing this screen I can 
> see jobs that have been completed. Jobs that are pending. 
> (Received faxes go to a folder on my hard-drive.)
> Problem: 1. If I send a fax and then want it to stop I am 
> denied access. It asks for my name and password. I put in the 
> main name and password for the machine (administrator), but 
> it won't accept it. Is there some other password I might have 
> set months ago that I forgot about? Can I remove some file 
> and reset my password for the CUPS?
> Problem 2: Is there anyway to control the modem? Hang it up? 
> Disengage it? ? Reset it?
> I formerly used Global Village's software for faxing and it 
> was very good. Reliable. I could see just where I was in the 
> sending process and what had been either sent or received. I 
> rely on my computer for faxing. I need something reliable. If 
> not this process is there some software that will work with 
> the modem and do what I require? Any help is greatly appreciated.


1 - You usually login to the Admin area of CUPS using the root username
and password, which is *usually* disabled by default in OSX. You will
need to enable this using the NetInfo Manager. (off the top of my head
is in /Applications/Utilities/NetInfo Manager) This will then allow you
to do what you wish.

*Think* you should be able to allow a different user to admin CUPS using
the web interface, hence obviating the need to enable root, but you'll
need to edit the cupsd.conf file to achieve this.

2 - Yeah, the GV software was nice under OS 9, unfortunately they are no
more :(  This area of OS X is to be honest quite poor and I have yet to
find a nice solution (anybody out there found one). On my TiBook,
however it came with FaxSTF from SmithMicro (is an older one so came
with Jaguar which had no faxing ability at the OS level). This is quite
a bit nicer in that it does have reporting and additional features
regarding faxing (scheduling for cheap-rate phone times, etc). Also
interacts with the OSX Address Book and has tools to *fiddle* with the
modem. Admittedly it isn't quite as fluid as the OSX software, but is
better regarding the reporting et al. However it still doesn't really
have the flexibility you used to have with the GV software.



More information about the cups mailing list