passwd.md5 missing

johnny johnny at
Sun Jan 2 12:08:16 PST 2005

On Sat, 01 Jan 2005 21:00:07 -0500, nv wrote:

> johnny wrote:
>> I've been trying to install a printer in Mandrake 10.1. I keep getting a
>> client-error-not-authorized message from lpadmin. My research indicates
>> that I need to add users to the passwd.md5 file using lppasswd. That file
>> (passwd.md5) is nowhere on my PC. I tried uninstalling and re-installing
>> the cups rpm packages but the file is still missing. So, I tried using the
>> latest cvs. That file is STILL missing. I have no clue as to why this is
>> happening. Google is no help. I would assume that when CUPS is installed
>> it would automatically create the password file with at least root as an
>> authorized user. CUPS admin never prompts for a password also. What's the
>> deal? I never had this problem with earlier versions of Mandrake. I even
>> tried a fresh install of ML 10.1.
> Try,. creates passwd.md5 
>        lppasswd - add, change, or delete digest passwords.
>        lppasswd [ -a ] [ -g groupname ] [ -x ] [ username ]
> linux:~ # lppasswd -a root -g sys
> Enter password:
> Enter password again:
> linux:~ # lppasswd -a xxx  -g sys
> Enter password:
> Enter password again:

It worked after another fresh install. The only thing that I did
differently was format /var (which I hadn't done).

More information about the cups mailing list