How does CUPS support IPP, number-up from kprinter doesn't work for ps job

anonymous yliu0131 at
Wed Jan 19 17:05:18 PST 2005

I'm using Suse 9.1, CUPS 1.1.20

Senario 1:
Tried to print a postscript document with kprinter. Set pages per sheet to 
Only one sheet came out with gabbage on it. (Used HP 4345 with HP LaserJet 
4300 Postscript PPD file)

Verified that kprinter is sending 
"multiple-document-handling=separate-documents-collated-copies number-up=4" 
as option.
There's also a file in /var/spool/cups/c00712    (ipp control file?)

Senario 2:
Also tried to priint text file with kprinter, number-up = 4
Job prints perfectly with 4-up.

Senario 3:
Tried to print text fiile 4-up to a file and print the file to a CUPS raw 
queue. Job prints with 4-up.

What's the workflow for CUPS to handle ipp attributes?
Based on Senario 2 and 3, CUPS must have applied those ipp attributes in 
pstops filter? If so, why there's a ipp control file?

Does it make a difference on which printing port I use on the printer?

>From CUPS error_log, different backend was launched (socket backend and ipp 
backend) but it looks like they are producing the same result.

Is 9100 port able to handle ipp request?


More information about the cups mailing list