Landscape not working when using a shared printer

Michael Guntsche mike at
Tue Jan 11 09:12:16 PST 2005


I have a little problem printing a page in landscape mode.

My setup:

Linux-Server running CUPS 1.1.23 + gimpprint 4.2.7
Powerbook MacosX 10.3.7 running cups 1.1.20rc1 according to cups-config.
An Epson Photo 870 printer is connected to the Server and Browsing is 

The notebook discovers the printer and I am able to print without any 
problems. Yesterday I had to print a page in landscape mode. I created a 
PDF file and printed it. The file looked good in preview but came out in 
portrait mode.
Next I tried printing the same PDF directly from the server and the page 
was printed in landscape mode without a problem.
Finally I tried to print via SAMBA. So I added the printer as windows 
printer on the MAC, chose the correct driver and tried printing the page.
This worked too.
So it seems the only problem I have is printing to the shared CUPS 

Is it possible that the page gets turned twice during the process. First 
by the CUPS system running on the MAC and then by the server?
Or is the landscape mode just ignored in ths special setup?

Thanks in advance,

More information about the cups mailing list