CUPS Windows Postscript Drivers

Michael Sweet mike at
Wed Sep 28 09:37:24 PDT 2005

stefan.hildenbrand at wrote:
> I tried to install the new drivers via cupsaddsmb (the one from the trunk) but at first it did not work. This is because (at least I think that's the reason):

That does appear to be a bug - fixed in trunk now...

>  'cupsaddsmb' looks for a file named 'cupsdrv6.dll' which is not
>   present in the svn repository. That's why 'cupsaddsmb' fails.
>   Therefore I linked cupsdrv6.dll -> cupsps6.dll
>  This worked for installing the drivers in /etc/samba/drivers, however,
>  printing a test page did not work. This is because cups6.inf/.ini refer
>  to the file 'cupsps6.dll' which is not present in /etc/samba/drivers
>  (cupsaddsmb does not copy it).

That should be fixed up now...

>  After adding cupsps6.dll to /etc/samba/drivers it worked.
> Besides, cupsaddsmb also looks for the 'ps'-files and fails if they are not present in /usr/share/cups/drivers

Yes, the CUPS drivers still depend on the Microsoft PS drivers, as
covered in the man page...

Michael Sweet, Easy Software Products           mike at easysw dot com
Internet Printing and Publishing Software

More information about the cups mailing list