[cups.general] Can't print with Samsung ML-1250 on Fedora 7

Steven P. Ulrick lists-cups at afolkey2.net
Thu Jun 14 17:11:45 PDT 2007

Hello, Everyone
Up until my recent fresh install (not an upgrade) of Fedora 7, my
Samsung ML-1250 Laser Printer (USB) was working perfectly.  In
conjunction with Cups, this Samsung printer has worked perfectly with
every version of Red Hat/Fedora Core that I have ever thrown at it.
But now, starting with the above referred to fresh install of Fedora 7,
printing no longer works.  I initially reported this to the Fedora list,
but I don't seem to be getting much action over there.  If you determine
that this is not a Cups issue, please let me know what I should file a
bug report on, and who I should file it with.

"rpm -qa | grep cups " returns the following:
[root at afolkey2 steve]# rpm -qa | grep cups
[root at afolkey2 steve]#

Below you will find a link to the beginning of the entire thread on the
Fedora list.  After that is the content of the first message of that
thread. For some of you more cups-specific people this first message
(with links to screenshots) may be enough to get me up an running.

Thank you in advance for any help you can give me, and thank you for
your patience...

Steven P. Ulrick

Begin message from Fedora-list:

 I have just upgraded from Fedora Core 6 (fully updated) to
Fedora 7 (now fully updated as well). I did a fresh install, not an
upgrade. One of the Very Few problems that I have been having since I
did that fresh install of Fedora 7 is that I can't print on my Samsung
ML-1250 Laser Printer.  Right before I installed Fedora 7, this printer
worked great.  As far as I can remember, this printer has "Just Worked"
ever since Fedora Core 1 (and perhaps the last few free versions of Red
Hat Linux.  It has "Just Worked" to the point that it had always been
auto-detected and it was just ready to use when I booted into whatever
fresh install I had just done.

Since printing has always worked so beautifully for me before, I don't
know anything about fixing it on my own :)  I have haunted Google ever
since Fedora 7 was released and I have found nothing that seems to
apply to my situation.

All I can give you is the following:I am running Fedora 7, fully
updated.  My printer is a Samsung ML-1250 Laser Printer.  "cups" and
"hal" are both running on our system.  If I were to delete the printer,
unplug the cables and reboot (just to make sure the printer is gone)
and then reboot with the printer connected and turned on, it would get
re-added.  I just can't print...
ACTUALLY, I have printed a few test pages successfully.  This is wierd:
they wouldn't print unless I restarted Cups.  So the scenario there is
something like this:
1a. Print test page.
1b. Result: test page doesn't print.
2a. Restart cups.
2b. Test page prints

I cannot duplicate this behavior, but it has happened at least twice.

Here are links to all of my Cups logs as of 5:24pm Central Time (United

Trusting that you will need more information than I have provided, I
will be glad to provide whatever information I need to to help me get
my printer working again :)

More information about the cups mailing list