lpmove to remote host not working

Bernie bfb21 at comcast.net
Sat May 24 07:22:30 PDT 2008

When I try to lpmove a file to a remote host using this command:

lpmove -h qaprinter-5524 hplj8000a

I see these messages in the cups error_log on that remote host:

D [23/May/2008:09:51:39 -0400] cupsdAuthorize: No authentication data provided.
D [23/May/2008:09:51:39 -0400] cupsdSendError: 10 code=401 (Unauthorized)

On the remote host, I have printer sharing enabled, and the printer hplj8000a is published.  So, Looking at the man page for lpmove, I see you can pass a user name with the -U option like:

lpmove [ -E ] [ -h server[:port] ] [ -U username ] job destination

So I then tried the lpmove command with a -U and it keeps complaining that 'U' is an unknown option:

lpmove -h -U bernie qaprinter-5524 hplj8000a
lpmove: Unknown option 'U'!

I've tried the -U at different points in the command, and using the -E to enable encryption, and it still doesn't work.  How do I move a print job to a remote host?


More information about the cups mailing list