NEed help installing cups-filters, make install error, where can I get help?

Leon Goldman leon244 at
Thu Nov 1 09:27:18 PDT 2012

> Leon Goldman wrote:
> > I recently installed CUPS 1.6.1 and can't print because of "usupported
> > format". It was recommended I get the cups-filters and downloaded them and
> > tried to build them. I got through 'make', but get errors with 'make
> > install' which I do not understand and have no idea how to fix them. Where
> > can I get help understanding this:
> >
> > [user is leon]$>make install
> >   CCLD   parallel
> > parallel-parallel.o: In function `main':
> > /Data/Downloads/CUPS/cups-filters-1.0-20121031/backend/parallel.c:142:

> >
> > Any suggestion would be helpful. I have tried to Google the error, but
> > nothing useful so far. Thank you.
> You need the CUPS sources as well for compiling.
> Helge
Thank you. I apologize if this is a duplicate post, but I am not sure my reply the first time got posted.
I also apologize for my ignorance, but I had built and installed the CUPS 1.6.1 tarball before trying to build the cups-filters. Is not the tarball, the CUPS sources? Do I need to do something different, other than building CUPS out of the tarball? Do the cups-filters have to be within the working directory from which I build CUPS?

Thank you.

More information about the cups mailing list