Authentication problems

Bernd Eggink monoped at
Tue Nov 13 07:06:39 PST 2012

I'm on Crux-2.8. I had no problems with the first CUPS 5.4 installation, which was compiled from the sources; no patches, no configuration changes, everything worked fine. When adding a printer through the web interface, I had to enter a root password, and the system's root password was accepted.

Then, unfortunately, I played around with a different CUPS versions (6.1.1), and somehow managed to drive CUPS into a very strange state. Now my password is _never_ accepted, though it is 100% correct. And what really baffles me, this behaviour continues, even after removing CUPS completely (including /etc/cups, /var/run/cups, /var/cache/cups) and re-installing the same or another version. I probably am missing something. 2 questions:

1. How can CUPS be removed cleanly, so that really no setting survives?
2. I'd prefer to have no authentication at all, as I am the only user. How can this be done? I tried "DefaultAuthType None", but that didn't change anything.

Thanks in advance for any help!

More information about the cups mailing list