location of user-specific CUPS/postscript/lpr config files?

cameron mura seemura at gmail.com
Thu Nov 29 09:17:51 PST 2012

Hi all,

I'm wondering if anyone could point me to useful resources that describe where user-specific Postscript information/customizations/etc. are stored on a standard, vanilla Fedora installation (running CUPS)?  I really do mean user-specific (versus global) preferences, so I imagine the info/settings probably live somewhere in $HOME/, but my Linux/Fedora/CUPS printer config knowledge has become outdated and quite rusty... I tried some obvious things -- like blasting away the $HOME/.gtklp that exists if one has GtkLP installed (a GTK frontend to CUPS) -- but all this was to no avail, my page-scaling problem persists.  I've also searched extensively online for the info (queries like "linux postscript user customization file"), but still can't find anything.

A bit of backstory: Suddenly, any email I print from Thunderbird, by sending to the default print queue, ends up being scaled-down by a factor of ~0.8x, positioned flush-left and flush-bottom on the standard-sized (8.5"x11" letter) paper.  I learned the following from various troubleshooting efforts and tests:

1) problem is not the printer itself -- e.g., a simplex queue on the same printer works fine (problem is I use duplex)

2) problem is not Thunderbird-specific -- I initially thought I must have mung'd a t-bird setting in prefs.js or something like that, but turns out that's not the problem -- interestingly, this scaling problem does not occur if I print a PDF file to the troublesome print queue, but it does occur if I print a postscript file from any postscript-aware app (e.g. okular), which led me to conclude it's some generic postscript config problem...

3) this page mis-scaling problem even occurs if I do a simple 'echo "foo bar" | lpr' (as me), but does not occur if I issue the same command (as root, or another user)... So the problem is not global, but rather user-specific.

>From the above I deduced it's some user-specific Postscript (or CUPS?) weirdness, and was hoping this could be traced to something in $HOME, but for the life of me I can't get any further.... maybe I'm missing something obvious?!?  does anyone know where user-specific print config files are stored? (I tried snooping around $HOME/.gconf and usual places like that, but not 100% sure what sort of file I'm searching for and I don't see anything obviously awry).

...any tips or pointers to online resources would be greatly appreciated!

More information about the cups mailing list