[cups] Datamax I4208 LPT Printing

Johannes Meixner jsmeix at suse.de
Thu Nov 20 00:53:36 PST 2014


On Nov 19 21:40 Hans-Christian Koch wrote:
> I have an old Datamax I 4208 label printer which is connected via LPT. Under
> pure dos it works fine and I can print my files but it won't work under
> Ubuntu. Actually I don't even need a real driver, all printer control signs
> are included in the files you send to the printer. So I tried adding the
> printer in CUPS, it was not detected but I chose LPT and added it as "raw
> queue", set as default.  It won't print. I tried cat file.txt | lpr -l but
> it just does nothing.
> I tried parallel port with ECP, SPP, EPP. However I also tried an USB-LPT
> cable. Now the printer is detected by CUPS and I add it as raw queue again,
> set as default. I may print one label now but no more until I restart the
> computer.

If I understand it correctly the Datamax I 4208 printer's built-in/native
connection is via the parallel port.

In this case you need first and foremost to get the parallel port
working under Ubuntu.

I do not have Ubuntu but making the parallel port work under any
nowadays Linux distribution should be (hopefully) more or less the same
because in the end it is the kernel that makes a parallel port working
and nowadays Linux distributions should use similar kernels.

Via Googling for "ubuntu parallel port" I found something but I cannot
decide what may apply for your particular (unknown) Ubuntu version.

You may also have a look at "Parallel port printers" in

See in particular what kernel modules must be usually loaded.

You may also inspect the output of the command "dmesg" regarding
parallel port e.g. by using

   dmesg | egrep -i 'parallel|parport|ppdev|lp'

I don't know it the Datamax I 4208 printer can print plain ASCII text
directly so that the command

   echo -en "\rHello\r\f" >/dev/usb/lp0

would result one sheet with the word Hello printed on it.

If the Datamax I 4208 printer cannot print plain ASCII text directly,
send one of your files that contains the right control signs for that
printer directly via the parallel port as follows (as root):

   cat your_file >/dev/usb/lp0

Perhaps you may have to send an additional formfeed afterwards
to enforce the printer to eject the sheet as follows:

   echo -en "\f" >/dev/usb/lp0

Provided you can print this way, it will also work to print
via a "raw" queue in CUPS.

Kind Regards
Johannes Meixner
SUSE LINUX GmbH -- Maxfeldstrasse 5 -- 90409 Nuernberg -- Germany
HRB 21284 (AG Nuernberg) GF: Jeff Hawn, Jennifer Guild, Felix Imendoerffer

More information about the cups mailing list