[cups] PostScript to cups-pdf

Johannes Meixner jsmeix at suse.de
Thu Jul 7 02:58:28 PDT 2016


On Jul 6 18:55 Keith Sieman wrote:
> I have an output file being spooled to CUPS containing PostScript. I want
> to have it interpreted and have cups-pdf generate the file as instructed by
> the code in the PostScript. However, cups-pdf just takes the input and
> simply prints out the code line by line. I've tried using the Generic
> Postscript Driver to drive a cups-pdf printer, but with the same result. Is
> there a guide somewhere, or could someone assist me with getting it to
> interpret the PostScript code being sent to it?

As far as I can understand what you like to tell
your issue seems not to be related to cups-pdf

I think your issue is related to what kind of file type
your PostScript input gets autodetected.

CUPS has some *.types files that specify how various kind
of input gets autodetected as what kind of file type.

Usually a CUPS *.types file specifies something like
application/postscript   ai eps ps string(0,%!) ...
so that files that start with the standard way how
a PostScript file has to start are autodetected
as file type "application/postscript".

A standard PostScript file has to start with that line:

For what you can do for a more detailed analysis see
therein see in particular the section about
how to get CUPS debug messages.

Kind Regards
Johannes Meixner
SUSE LINUX GmbH - GF: Felix Imendoerffer, Jane Smithard,
Graham Norton - HRB 21284 (AG Nuernberg)

More information about the cups mailing list