[cups] Fedora does not discover Printers

Brett I. Holcomb biholcomb at l1049h.com
Tue Jul 12 12:04:42 PDT 2016

Just a summary for other owners of the Epson WF-3540.  I installed the 
Epson drivers from epson.com on the print server but no matter what I 
did they were not discovered by the client.  I ended up putting the 
Epson drivers on the client, too which kind of defeats the purpose of a 
print server.  However, I think it's because of the epson driver setup.  
Epson has a network piece that must be installed and once that's 
installed CUPS sees the printer on the server. However, the network 
piece depends on the drivers so you have to install them both.1

When I get some time I'll probably create a test print server and put 
the Centos Epson drivers on it and then spin up a client and see if it 
can see the printer.

On 06/08/2016 10:09 PM, Brett I. Holcomb wrote:
> I worked around having to use * as a ServerAlias by adding the 
> ServerName to a ServerAlias entry.
> Now I just have to figure out why some client applications print with 
> a huge font.
> On 06/04/2016 07:09 PM, Brian Potkin wrote:
>> On Sat 04 Jun 2016 at 16:08:33 -0400, Brett I. Holcomb wrote:
>>> On Sat, 2016-06-04 at 20:02 +0100, Brian Potkin wrote:
>>>> Install avahi-daemon on server and clients. Install cups-browsed on 
>>>> the
>>>> clients. Read documention for cups-browsed.
>> Also read cups-browsed.conf because it is uncertain whether you need
>> BrowseAllow if the server is doing only Bonjour broadcasting.
>>> Did that earlier today.  In client I set BrowseAllow as all  and had to
>>> add a Browsepoll for the server.  The server file was left as is but it
>>> still did not work.  That let the client see the printers but the print
>>> button was grayed out.  I finally found a bug report (https://bugs.debi
>>> an.org/cgi-bin/bugreport.cgi?bug=530027) in which changing ServerAlias
>>> to * worked for some and it did for me.  Once I added that to the
>>> server /etc/cups/cupsd.conf and restarted cups the print button was no
>>> longer grayed out.  Based on the cups docs this is probably not a good
>>> thing since it allows all but it works.
>>> The server actual host name is x.sub.mydomain.net and it has a CNAME of
>>> prtsrv1.sub.mydomain.net which is what I put in BrowsePoll. The
>>> server /etc/cups/cupsd.conf file has ServerName x.sub.mydomain.net and
>>> I tried ServerAlias of prtsrv1.sub.mydomain.net and while that allows
>>> WebUI access the cups log file complained about the client using an
>>> invalid host and listing x.sub.mydomain.net:631 as the invalid host.
>>>   Changing to ServerAlias * fixed that.
>>> Now to find out why  a simple text file print gives me huge font.
>>> Thanks for the help.
>> I snipped too much of your first mail and lost sight of
>>    >...since my Fedora client is on a different subnet than the server.
>> I have no experience of dealing with avahi broadcasting between subnets,
>> The daemon has a "reflector" option which might be what you need and
>> this might be useful:
>>    https://www.novell.com/support/kb/doc.php?id=7015851
>> Regards,
>> Brian.
>> _______________________________________________
>> cups mailing list
>> cups at cups.org
>> https://www.cups.org/mailman/listinfo/cups
> _______________________________________________
> cups mailing list
> cups at cups.org
> https://www.cups.org/mailman/listinfo/cups

More information about the cups mailing list