[cups] Installing Brother HL-2270DW

Daniel Lamb daniel at dwlamb.com
Fri Dec 8 10:23:52 PST 2017

Thank you to all who replied on this topic.  This problem has been 
resolved and I am sharing how I did it.

These instructions are based on the support site for Brother USA 
That page is distinct from the pages found for Brother Canada 
which are similar for Brother Germany, Brother UK, etc.

Avoid the Driver Install Tool which is described as "The tool will 
install LPR, CUPSwrapper driver and scanner driver (for scanner 
models)." That description gives the impression it is an all-in-one and 
more up-to-date than older install packages listed. Instead, use the LPR 
printer driver and CUPSwrapper printer driver or Generic LPR printer 
driver and Generic CUPSwrapper printer driver.  At the time of my 
original post, it was after having tried the Driver Install Tool. The 
instructions found on the support site for Brother USA 
are easier to follow.

For users trying to install on a 64-bit Linux system, it is worth 
enabling 32-bit architecture with sudo dpkg --add-architecture i386.

Have a great day.

On 17-12-02 02:41 PM, Daniel Lamb wrote:
> I am attempting to install a Brother HL-2270DW and not having success 
> to print.  I have tried to install with the Brother Driver Install 
> Tool and through CUPS using the Foomatic driver.  Through CUPS the 
> print job status is ' Idle - "Filter failed" '.
> I am installing on Ubuntu 14.04 64-bit.  This printer was successfully 
> installed on Ubuntu 14.04 32-bit.  I noticed during the install the 
> Brother install tool has i386 instead of amd64 in the file name, 
> indicating to me this is a 32-bit deb file instead of 64-bit.  
> Searching for a 64-bit install file has not yielded anything.
> Hope someone can help
> _______________________________________________
> cups mailing list
> cups at cups.org
> https://lists.cups.org/mailman/listinfo/cups

More information about the cups mailing list