[cups] If you can read this, you are using the wrong driver for your printer.

Paul Neuwirth mail at paul-neuwirth.nl
Mon Apr 16 11:54:08 PDT 2018


On Mon, 16 Apr 2018 20:16:38 +0200
Till Kamppeter <till.kamppeter at gmail.com> wrote:

> Hi,
> 
> I have also a very flexible, configurable implementation of text-only 
> printer support in cups-filters. If you have a not too old
> cups-filters (1.10.0 or newer) on your system, you will have a
> "Generic Text-Only Printer" under the manufacturers/models to choose
> on your system. If you choose this model you get your printer set up
> with a PPD which accepts only text files and under its "Installable
> Options" you can configure everything needed, encoding, line ends,
> margins, paper sizes and how many columns and lines fit on a page,
> paginated or continues printing, ...
> 
> This should suit all text-only printing needs, if not, suggestions
> and patches are welcome.
> 
>     Till
> 
> 

unfortunately I cannot install a recent cups-filters
# zypper up cups-filters
Problem: cups-filters-1.20.2-81.1.x86_64 obsoletes cups-filters-ghostscript < 1.20.2 provided by cups-filters-ghostscript-1.8.2-62.11.x86_64
 Solution 1: Following actions will be done:
  remove lock to allow removal of cups-filters-ghostscript-1.8.2-62.11.x86_64
  remove lock to allow removal of cups-filters-foomatic-rip-1.8.2-62.11.x86_64
  remove lock to allow removal of cups-filters-cups-browsed-1.8.2-62.11.x86_64
 Solution 2: do not install cups-filters-1.20.2-81.1.x86_64


I need those cups-filters (gs, foomatic-rip) not only for this printer..
openSUSE Leap 42.2 by the way


More information about the cups mailing list