CUPS Windows Postscript Drivers

stefan.hildenbrand at stefan.hildenbrand at
Wed Sep 28 08:32:29 PDT 2005

I tried to install the new drivers via cupsaddsmb (the one from the trunk) but at first it did not work. This is because (at least I think that's the reason):

 'cupsaddsmb' looks for a file named 'cupsdrv6.dll' which is not
  present in the svn repository. That's why 'cupsaddsmb' fails.
  Therefore I linked cupsdrv6.dll -> cupsps6.dll

 This worked for installing the drivers in /etc/samba/drivers, however,
 printing a test page did not work. This is because cups6.inf/.ini refer
 to the file 'cupsps6.dll' which is not present in /etc/samba/drivers
 (cupsaddsmb does not copy it).

 After adding cupsps6.dll to /etc/samba/drivers it worked.

Besides, cupsaddsmb also looks for the 'ps'-files and fails if they are not present in /usr/share/cups/drivers


> Anonymous wrote:
> >>No, the repo also includes the compiled DLLs, since you don't just
> >>need a compiler, you need the whole Windows DDK.
> >
> >
> > Will they work with the version(1.1.23) of CUPS that I am using?
> Yes, with the caveat that you need to update the cupsaddsmb program
> in 1.1.23.
> > Can I use them with cupsaddsmb to prepare them for Windows XP automatically downloading them?
> You'll need to use the cupsaddsmb.c sources from the repo, since we
> needed to fix the CUPS driver support post-1.1.23...
> --
> ______________________________________________________________________
> Michael Sweet, Easy Software Products           mike at easysw dot com
> Internet Printing and Publishing Software

More information about the cups mailing list