[cups.general] Re: CUPS Windows Postscript Drivers

C.Lee Taylor leet at leenx.co.za
Thu Sep 29 03:08:39 PDT 2005

Greetings ...

	Instead of modifying the source files, I figured out how to do the 
same, from bash ... would be nice to have perl, python or bash file, 
which does not need to be compiled to work ...

	Below is a very basic way that I did it ... would be nice to be able to 
do some of the things the c problem does, but I'm really not a 
programmer ... I have ask before on the list for something like this, 
but got no answer ... I too am sure that I saw something like this on 
the samba or cups lists, but I could not find it when I went looking for 
it ... Hope this helps ...


# First, copy the files into the printer share ...
smbclient //fc4test1/print\$ -U'Administrator%password' \
     -c 'mkdir W32X86; put /etc/cups/ppd/N_T_Test.ppd 
W32X86/N_T_Test.ppd; put /usr/share/cups/drivers/ps5ui.dll 
W32X86/ps5ui.dll; put /usr/share/cups/drivers/pscript.hlp 
W32X86/pscript.hlp; put /usr/share/cups/drivers/pscript.ntf 
W32X86/pscript.ntf; put /usr/share/cups/drivers/pscript5.dll 
W32X86/pscript5.dll; put /usr/share/cups/drivers/cups6.ini 
W32X86/cups6.ini; put /usr/share/cups/drivers/cupsps6.dll 
W32X86/cupsps6.dll; put /usr/share/cups/drivers/cupsui6.dll 

# CUPSv5 (NT4)
#rpcclient fc4test1 -N -U'Administrator%password' \
#    -c 'adddriver "Windows NT x86" 

# CUPSv6 (Win2K)
rpcclient fc4test1 -N -U'Administrator%password' \
     -c 'adddriver "Windows NT x86" 

# Win2K (Win2K)
#rpcclient fc4test1 -N -U'Administrator%password' \
#    -c 'adddriver "Windows NT x86" 

# Set the driver ...
rpcclient fc4test1 -N -U'Administrator%password' \
     -c 'setdriver N_T_Test N_T_Test'

 > I tried to install the new drivers via cupsaddsmb (the one from the
 > trunk) but at first it did not work. This is because (at least I think
 > that's the reason): 'cupsaddsmb' looks for a file named 'cupsdrv6.dll'
 > which is not present in the svn repository. That's why 'cupsaddsmb'
 > fails. Therefore I linked cupsdrv6.dll -> cupsps6.dll This worked for 
 > installing the drivers in /etc/samba/drivers, however, printing a test
 > page did not work. This is because cups6.inf/.ini refer to the file
 > 'cupsps6.dll' which is not present in /etc/samba/drivers (cupsaddsmb
 > does not copy it). After adding cupsps6.dll to /etc/samba/drivers it
 > worked. Besides, cupsaddsmb also looks for the 'ps'-files and fails if
 > they are not present in /usr/share/cups/drivers Stefan

 >>>> >>No, the repo also includes the compiled DLLs, since you don't just
 >>>> >>need a compiler, you need the whole Windows DDK.
 >>> >
 >>> >
 >>> > Will they work with the version(1.1.23) of CUPS that I am using?
 >> Yes, with the caveat that you need to update the cupsaddsmb program
 >> in 1.1.23.
 >>> > Can I use them with cupsaddsmb to prepare them for Windows XP 
automatically downloading them?
 >> You'll need to use the cupsaddsmb.c sources from the repo, since we
 >> needed to fix the CUPS driver support post-1.1.23...

More information about the cups mailing list