[cups.general] CUPS can't find printer (sort of)

Steven P. Ulrick ulrick2 at faith4miracle.org
Wed Jul 21 12:53:35 PDT 2004

On Wed, 21 Jul 2004 11:50:51 -0700
Doctorcam <cam at ellisonet.ca> wrote:

> * Steven P. Ulrick (ulrick2 at faith4miracle.org) wrote:
> > Hello :)
> > Take courage, my friend :)  You are not alone :)  I don't know what
> > caused it, and I don't know what ended up permanently fixing it, but
> > I did discover a workaround that worked every time.  In my case,
> > when I switched runlevels (I Suppose that rebooting would have done
> > it, I never tried it :)) when I came back to runlevel 5, our printer
> > was "gone"  My workaround, even though the startup messages said
> > that CUPS had started ok, was to run:
> > /etc/init.d/cups restart
> > After doing this, in KControl, a few times I just sat there and
> > watched our printer magically reappear :)  Then all was well.
> > (I use Fedora Core 2.  If you don't, the command I gave might need
> > to be slightly altered for your system.)
> Restarting cupsd does not have any impact on this.  Re-installing the
> printer does, without exception.  The printer will go off-line at
> times (and needs to be power-cycled), which triggers the lock-up.  My
> guess is that it is not actually the printer that is at fault, but
> something in the USB software.  What is bizzare is that cups will not
> allow access to anyone, including root. Running at debug level
> provides no clues that I can see. 
> Cheers
> Cam

Hello, Cam :)
I guess that your experience was not exactly the same as mine.  I had
tried reinstalling the printer, and that worked fine.  But in my case
(that's a key here: in my case) I found out that I did not need to
reinstall the printer, I only needed to restart CUPS.  The printer was
there in every configuration file that I looked at, it was just that
nothing could see it.  I don't know why "/etc/init.d/cups restart" was a
completely successful workaround 100% of the time, I just know that it

Also, let's say you are logged in, your system is running, and all
appears well.  Your printer is recognized, and you know that it is
functional.  Are you saying that your printer dissapears even if you
don't logout and log back in?  Or without even switching runlevels? 
EVERYTIME I switched from runlevel 5 to runlevel 1 and back to runlevel
5 again, my printer dissappeared!  Everytime I got full functionality
back by restarting CUPS.  (I need to add here that all the messages that
everytime I tried this experiment, the message that came by relating to
CUPS starting up, always said "OK") My printer never dissappeared if I
was just logged in and never switched runlevels.  I ask these questions
of you, not to question your understanding of this problem, but so that
someone else on this list who has FAR more knowledge of these things
than I (that could be virtually everyone :)) might read this and it
might help them see what the cause of this seemingly common problem is

Anyway, have to get ready to go to work :)
Steven P. Ulrick

More information about the cups mailing list