How does CUPS support IPP, number-up from kprinter doesn't work for ps job

Helge Blischke h.blischke at
Thu Jan 20 04:32:18 PST 2005

anonymous wrote:
> I'm using Suse 9.1, CUPS 1.1.20
> Senario 1:
> Tried to print a postscript document with kprinter. Set pages per sheet to
> 4.
> Only one sheet came out with gabbage on it. (Used HP 4345 with HP LaserJet
> 4300 Postscript PPD file)
> Verified that kprinter is sending
> "multiple-document-handling=separate-documents-collated-copies number-up=4"
> as option.
> There's also a file in /var/spool/cups/c00712    (ipp control file?)
> Senario 2:
> Also tried to priint text file with kprinter, number-up = 4
> Job prints perfectly with 4-up.
> Senario 3:
> Tried to print text fiile 4-up to a file and print the file to a CUPS raw
> queue. Job prints with 4-up.
> Question:
> What's the workflow for CUPS to handle ipp attributes?
> Based on Senario 2 and 3, CUPS must have applied those ipp attributes in
> pstops filter? If so, why there's a ipp control file?
> Question:
> Does it make a difference on which printing port I use on the printer?
> socket://ipaddress:9100
> ipp://ipaddress:631/ipp
> From CUPS error_log, different backend was launched (socket backend and ipp
> backend) but it looks like they are producing the same result.
> Is 9100 port able to handle ipp request?
> Thanks

Post (an URL to) the PostScript file that didn't print correctly. I
suspect that the PS file
contains statements that defeat what the pstops filter inserts inbto the
jov for n-up printing.


Helge Blischke
SRZ Berlin | Firmengruppe besscom
tel: +49 30 75301-360

More information about the cups mailing list