Cups denying access to printer

Anonymous anonymous at
Sun Jan 23 10:01:50 PST 2005

For some obscure reason, my Cups server decided to suddenly stop accepting printing jobs. The error_log contains the following lines:

D [23/Jan/2005:12:49:08 -0500] print_job: auto-typing file...
D [23/Jan/2005:12:49:08 -0500] print_job: request file type is application/vnd.cups-raw.
D [23/Jan/2005:12:49:08 -0500] check_quotas: requesting-user-name = 'Benoit'
I [23/Jan/2005:12:49:08 -0500] Denying user "Benoit" access to printer "LaserJet4"...
D [23/Jan/2005:12:49:08 -0500] Sending error: client-error-not-possible
D [23/Jan/2005:12:49:08 -0500] ProcessIPPRequest: 7 status_code=404

My server is an old headless Pentium 100Mhz, it doesn't even have a keyboard and I access it from ssh. I printed a job late Friday night without any problem but on Saturday there is no way now to print anything anymore. And I can assure you nobody accessed the server meanwhile. No matter from where I try to print, I get the same error (I tried to print a text file directly from the server as root with the command "lp test.txt" and the shell returned this error: "lp: unable to print file: client-error-not-possible").

I never messed with the quotas (I left the cupsd.conf with the default settings for this).

Anybody knows what could be the problem? How can the server stops working correctly all of a sudden?


Benoit Giroux

More information about the cups mailing list